Google Chromebook Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi all,

My parents have just bought a samsung chromebook as a quick tool for browsing/surfing around the house.

Generally they are very pleased, great battery life, loads instantly from sleep, simple to use etc.. exactly what they had wanted.

There is one quirk however that I wonder if anyone else has experienced.

They asked me to take a look at it because they claimed certain web pages would't load. I didn't really believe them and thought it must be something simple.. but actually they are right. Hotmail simply refuses to load.. rightmove.co.uk also doesn't load. For some reason when I tried to type this very message on this forum it was fine typing in.. but then I tried to submit this post four or five times and just timed out on the connection every time.

I have been scratching my head and there is no reason I can think of for this behaviour or what is upsetting it. Nobody else seems to be reporting similar problems, and when pages do load they load quickly and with no problems (ie, it's not a connection problem). No other computer on the same network has this problem.

So my last resort is to try doing a factory reset (not something I'm especially keen to do with a brand new computer). Before I do, is there anything anyone else can recommend trying? It just seems completely bizarre.

Oh, finally (an easy one), how do you "right click" on one of these things? no matter where I click it seems to left click and I can't find any options under touch pad settings.

Any help appreciated!

Thanks,

Lib
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 · (Edited)
Ok.. that's what I thought :D

I'll run a factory restore and see whether it miraculously cures it.

Failing that it's going back to the shop.Shame.

I'll post back if I have any success or discover anything useful.

[edit to add: tip's cap to Chrome-guy for his excellent instructional on restoring factory image]
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
The new image seems to have cured all browsing issues (for now at least).

I've also discovered how to right click from having now seen the start up tutorial.

The two finger click might take some getting used to but seems to work fine :)
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Well.. seemed fine for about an hour.

Now reverted to not loading some web pages. Hotmail seems to be the main issue.

Everything else loading fine for now. Damn.. not sure what else to try. Looks like it may be going back :(
 
1 - 4 of 4 Posts
Top