Google Chromebook Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have an Android App that runs on a Chromebook as Device Administrator (BIND_DEVICE_ADMIN, DeviceAdminReceiver etc.). The purpose in gaining that level of access was to be able to run commands like ...
  1. cat /dump_vpd_log --full -stdout
  2. dmidecode --type 17
  3. battery_test 10
  4. memory test
  5. storage_test_1
  6. storage_test_2
This is all to collect system and diagnostic data on the chromebook, power wash it and report the data back via WiFi to a server that collects the information and records the erasure and device specs for re-use or re-sale. I have the app asking for the Device Administrator Privileges and that part works as does the data transfer at the end. Getting the data I need from the other commands doesn't work, it always crashes with "permission denied" errors. I tried "sudo" in front of the commands and that crashes with "permission denied" as well. I assumed having Device Administrator Privileges was the issue and now that I have them, nothing changed, same errors.
Has anyone ever tried this and gotten it working? Any guidance would be much appreciated!
Thank you!
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top